[Solved] DXF import -- thick lines

Having tech problems? Post them here and do not worry, there is always a solution for you.
WCraig
Posts: 5
Joined: Fri Feb 15, 2019 5:22 pm
Country: Canada

[Solved] DXF import -- thick lines

Post by WCraig »

Hi:

I get this when I import a DXF:
CADintosh screen grab 2019Oct18.jpg
CADintosh screen grab 2019Oct18.jpg (314.69 KiB) Viewed 1389 times
It should look like:
Holescreek Logan Lathe Ball Turner Full 040206 resized.jpg
Holescreek Logan Lathe Ball Turner Full 040206 resized.jpg (297.67 KiB) Viewed 1389 times
The source DXF is at:

http://www.lepton.com/metal/ball_turner.html

Is the source DXF deficient or is there something to tweak in CADintosh to get a better import?

Many thanks,

Craig

User avatar
forum_adm
Site Admin
Posts: 845
Joined: Fri Dec 23, 2016 9:41 am
Location: Germany
Country: Germany

Re: DXF import -- thick lines

Post by forum_adm »

The main problem is: the dxf format has no scale.
So, you have to adjust the scale / rescale the drawing after the import.

Please e-mal the imported file zipped to support@lemkesoft.de
I will check it.

User avatar
forum_adm
Site Admin
Posts: 845
Joined: Fri Dec 23, 2016 9:41 am
Location: Germany
Country: Germany

Re: DXF import -- thick lines

Post by forum_adm »

Please view my short tutorial video at:
https://www.lemkesoft.info/forum_movies ... escale.mp4

Thorsten

WCraig
Posts: 5
Joined: Fri Feb 15, 2019 5:22 pm
Country: Canada

Re: [Solved] DXF import -- thick lines

Post by WCraig »

Thank you very much.

It appears this is related to an Imperial v. metric assumption, no? The scaling factor of (3/0.12) is 25 which is suspiciously close to the number of millimetres in an inch (25.4).

Could it be possible to have a setting for importing DXF files that controls the default scale and/or measurement units?

Thanks again for your quick assistance.

Craig

User avatar
forum_adm
Site Admin
Posts: 845
Joined: Fri Dec 23, 2016 9:41 am
Location: Germany
Country: Germany

Re: [Solved] DXF import -- thick lines

Post by forum_adm »

The main problem is the missing scale in the dxf export.

So, normally the best is to correct the import scale after the import with a valid scale.