[Solved] Multiple selected images and Open With

Want to submit a new feature, an enhancement ? Do it here !
Post Reply
201990
Posts: 4
Joined: Mon Feb 11, 2019 12:08 am

[Solved] Multiple selected images and Open With

Post by 201990 » Mon Feb 11, 2019 1:19 pm

I have a small problem which is that when I select multiple images and use Edit With, it opens each image separately in the external editor.

For some apps this makes no difference, but in Preview for example, this means that a new window is created for each image, instead of a single window with a thumbnails drawer as you get when you open multiple images from Finder.

Another case is Quicksilver. When I drag multiple files onto Quicksilver in the dock, it puts all of them in the Quicksilver pane (screenshot below). (This even works from GraphicConverter.) But if I use the "Edit With" menu, the Quicksilver pane activates and deactivates rapidly and only the last item is selected. I would prefer to use the Edit With menu because then I could bind a keyboard shortcut to it and not have to move the cursor.
Screen Shot 2019-02-11 at 12.15.45.png
multiple files in quicksilver
Screen Shot 2019-02-11 at 12.15.45.png (72.77 KiB) Viewed 335 times
Basically, if you could make it work the same way as the Terminal command

Code: Select all

open -a Quicksilver 1.jpg 2.jpg ...
, batch-sending the files to the target application, that would be ideal. Maybe as an option in preferences?

User avatar
forum_adm
Site Admin
Posts: 611
Joined: Fri Dec 23, 2016 9:41 am
Location: Germany
Country: Germany
Contact:

Re: Multiple selected images and Open With

Post by forum_adm » Tue Feb 12, 2019 8:57 am

Thanks for your note.

I added this to the latest BETA:
http://www.lemkesoft.org/beta.html

This feature requires macOS 10.10 or later.

Thorsten

201990
Posts: 4
Joined: Mon Feb 11, 2019 12:08 am

Re: [Solved] Multiple selected images and Open With

Post by 201990 » Tue Feb 12, 2019 11:04 am

Thank you! That was quick. It just so happens that I'm stuck on 10.9 for a few more months :oops:, but thanks for adding it!

Post Reply