[Solved] Images and image browsers are opened in the background

Having tech problems? Post them here and do not worry, there is always a solution for you.
rvaessen
Posts: 6
Joined: Sat Dec 31, 2016 5:30 pm
Location: Aurora, CO

[Solved] Images and image browsers are opened in the background

Post by rvaessen »

Thorsten -

I'm experiencing an issue with GraphicConverter that I can't seem to resolve. It has persisted for the last three betas that I've downloaded/used on my iMac. I'm currently using 11.1.3 (b4254) and macOS 10.15.2. I tried downloading new versions of the betas, but that didn't help. I tried downloading the latest stable release (11.1.2), but that hasn't helped either. The problem is confined to GraphicConverter, and restarting the computer hasn't helped.

I can't get GraphicConverter to move 'to the Front' of the Finder/Window. When launched it doesn't come to the Front. If I select, 'Window->Bring All to Front' it doesn't come to the Front. If I select 'Window->Cycle through Windows' or 'Window->Cycle back through Windows' nothing happens (even if I have already opened several images by double clicking on them in an image browser). GC will only come to the Front when I select a command that spawns a dialog window. Such as 'File->New->Image...', 'File->Open...'; anything that has the ellipsis (three dots) will cause all the open windows to come to the Front. None of the commands (including double clicking on an image in an image browser) without a dialog window will cause GC to come to the front (of the Finder/current desktop window). For example 'File->Browse Last' will open an image browser, but it is opened in the background and cannot be seen until I force all the open windows to the foreground by selecting a menu command which spawns a dialog window to appear.

This behavior extends to the Graphic Converter application as well. If I am working on some other application (for example Safari), and I then select GraphicConverter using the Application Switcher (Cmd-Tab), or click on the open GC application icon in the Dock, the application doesn't come to the foreground. If I click the application in the Dock a second time, then it comes to the foreground/front.

I suspect that I may have some corrupted preferences, but am unsure of which file(s) to delete. Is this limited to my installation? or have others reported it? Can you provide some troubleshooting assistance/guidance? Should I delete 'com.lemkesoft.graphicconverter11.plist', or some other file(s)?

- Robert

User avatar
forum_adm
Site Admin
Posts: 849
Joined: Fri Dec 23, 2016 9:41 am
Location: Germany
Country: Germany

Re: Images and image browsers are opened in the background

Post by forum_adm »

Hi Robert,

I have no other such report.
What happens if you trash the prefs with our First Aid app?
https://www.lemkesoft.info/files/graphi ... st_aid.dmg

Thorsten

rvaessen
Posts: 6
Joined: Sat Dec 31, 2016 5:30 pm
Location: Aurora, CO

Re: Images and image browsers are opened in the background

Post by rvaessen »

Thanks - That worked. Unfortunately, it trashed all my GC related preferences (19 files!). Now I have to rebuild all the settings.