[Solved] "don't have sufficient privileges" when saving files

Having tech problems? Post them here and do not worry, there is always a solution for you.
welchgregusa
Posts: 11
Joined: Sun Mar 08, 2020 5:06 pm
Country: USA

Re: "don't have sufficient privileges" when saving files

Post by welchgregusa »

Problem solved, and it was "my fault"—rather it was caused by the Bitdefender antivirus software running on my MacBook. I had previously disabled it, to see if that was the issue, and it seemed to make no difference. But when I was poking around the Bitdefender notifications area I found the following:
Feature: Anti-Ransomeware

An app you previously chose to block attempted to access your protected files again.
App: /Applications/GraphicConverter 11.app
We blocked the app to prevent it from altering the content of your protected files
Of course I never knowingly chose to block GC. I did some more testing, and found that for some reason Bitdefender automatically blocks GC when I launch it for the first time. If I go into the Application Accesses area (of Bitdefender) it says "Blocked" in red w/ GC. But I can change it to "Allowed" and viola (Bratsche) it works.

Thorsten: I am SO sorry to send you (and me) on a wild goose chase.
User avatar
buckyjunior
Posts: 8
Joined: Mon Jan 02, 2017 4:18 pm

Re: [Solved] "don't have sufficient privileges" when saving files

Post by buckyjunior »

What solved the problem for me was "overwrite the original" preference setting.

I have old non-GPS photos that I want to add EXIF GPS data, macOS Monterery V.12.3 and GraphicConverter 11.6. Permissions were correct, disk access was correct.

Problem solved for me. GC 4 EVR!

Thanks for the absolute BEST support.
Bucky
----------------------
Using GraphicConverter to convert graphics since version 4.3
----------------------